Wouldn't one name those variables dwOuter
and dwInner
instead? Having "var" in a variable's name looks quite redundant to me.
joerg smn
Posts
-
Code Neatness -
Algorithm ComplexityHi, maybe there is a way in between: Count the calls to non-trivial functions like trigonometrical ones in each algorithm and then time some iterations with only one of these calls so you can get an estimate on the weight of each of those function calls. This way you might not get a result like "A has O(n^2) and B has O(3n^2)" but "A's complexity is significantly higher than B's" or "both algorithms are about equal in complexity". Maybe put some tech talk on top of it noting that real-life complexity depends on platform used etc. :-)
-
Height of status bar?How can I get the handle? I tried the following from my View-class:
CMyView::OnInitialUpdate() { ... CRect rcStatusBar; CFrameWnd* pFrame = (CFrameWnd*) GetParent(); CStatusBar* pStatusBar = (CStatusBar*) pFrame->GetControlBar(AFX_IDW_STATUS_BAR); CStatusBarCtrl& statusBarCtrl = pStatusBar->GetStatusBarCtrl(); statusBarCtrl.GetWindowRect(rcStatusBar); ... }
But this leaves me with a CRect with the size of 0 height and 0 width...